GNU Xnee 3.05 'Merry X11-mas' released

We are pleased to announce the availability of GNU Xnee 3.05

GNU Xnee is a suite of programs that can record, replay and distribute
user actions under the X11 environment. Think of it as a robot that can
imitate the job you just did. GNU Xnee can be used to:
Automate tests
Demonstrate programs
Distribute actions
Record and replay ‘macro’
Retype the content of a file

Getting the Software
====================

http://ftp.gnu.org/gnu/xnee/xnee-3.05.tar.gz
http://ftp.gnu.org/gnu/xnee/xnee-3.05.tar.gz.sig

or one of the mirror sites as found in:

http://www.gnu.org/prep/ftp.html

Checksums
===========

md5sum:
0ba4ea4f6102bcc0b478f4a6fe787b0b  xnee-3.05.tar.gz

cksum:
3878268877 1666788 xnee-3.05.tar.gz

New in this release
===================

* Fixed bugs reported on bug-xnee@gnu.org:
“Bug report: libpanelapplet-2.0” (12/15/2009 11:07 AM)
“Bug report: No package ‘libgnomeui-2.0’ found”
(12/15/2009 11:03 AM)
“Configure Error” (12/15/2009 11:07 AM)
“Error in configure.” (12/15/2009 11:09 AM)
“Building from CVS” (12/17/2009 07:19 PM)

* Build changes:
configure bails out when building any gui
and no pkg-config installed

Better help during configure if no gtk, gnomeui found

Telling user to run configure with –enable-doc option set,
when building from CVS (make -f Makefile.cvs)

New file (README.cvs) to ease up for users building from CVS

2 responses to “GNU Xnee 3.05 'Merry X11-mas' released

  1. ********** ERROR **********
    ** pnee and/or gnee can not be built **
    **
    ** The following program/package is missing:
    ** gtk+-2.0 libgnomeui-2.0
    **
    ** Suggested solutions:
    ** 1) Build Xnee without pnee and gnee,
    ** ./configure –diable-gui –disable-gnome-applet
    **
    ** 2) Install the missing programs/packages
    ** If you are using Debian or Debian based distro
    ** (e.g Trisquel, Gnewsense, Ubuntu), try:
    apt-get install gtk+-2.0 libgnomeui-2.0
    **
    ** 3) If the programs/packages are installed (and not found) make sure they can be found in the PATH or other environment variable
    **
    **
    ********** ERROR **********

    • What is your question?

      The error message means you have to install the libs mentioned. If you need help doing so, either ask me and ill do my best or you can ask your distribution

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s